ComQi Media Player RMA Checklist


To request an RMA form please contact ComQi customer support desk (CSD):

Phone: 1-866-387-7667 Email: customersupport@comqi.com

 

Player fault:

1. Player does not power on

2. Player powers off on its own

3. F1 Boot Message or any BIOS issue

4. Disc boot failure

5. Video port failure

6. Audio/sound card failure

7. Ethernet port failure (No network light)

8. Noisy fan

9. ComQi splash page reboot loop

 

 

1. Player does not power on

þ Confirm that the power supply is plugged into a working outlet.

þ Confirm that you are using the correct power supply (Contact ComQi CSD if you are not sure).

þ Using a known-to-work power supply unplug the power cable from the player, plug back in and press the power button on the player. If you are not certain that the power supply is known-to-work, troubleshoot by testing the power supply with a known-to-work player.

 

2. Player powers off on its own

This is commonly a result of overheating.

þ Install the player in a well-ventilated location.

þ Make sure the player’s fan vents are free of dust buildup.

þ Check if the player feels hot to the touch.

 

3. F1 Boot Message or any BIOS issue

þ If the player powers on but fails to boot past any of its BIOS screens, reboot the player.

þ If the issue persists please send a photograph of the screen to ComQi CSD and request an RMA.

 

4. Disc boot failure

þ Confirm that you are using the correct power supply (Contact ComQi CSD if you are not sure).

þ Make sure that the attached monitor is set to the correct input, so that the boot-up splash pages can be visible. Also confirm that you are using a working video cable.

þ Power on the player and listen for the POST “beep” sound. If the player powers on but fails to boot, please request an RMA from ComQi CSD.

 

5. Video port failure

þ Verify the type of port in question (HDMI, VGA, DVI, DisplayPort, etc)

þ Confirm that you are using a working video cable.

þ Connect the player to a known-to-work monitor and confirm that the monitor is powered on and set to the correct input/source.

þ Confirm that the player’s video output is set correctly in EnGage Site Settings*:

*Note: The player must be connected to the network in order to download any settings changes. Please contact ComQi CSD if you are unsure about video output settings in EnGage.

þ Power on the player. If the player has fully booted (Check the connection status in EnGage to confirm this) do a screen capture in EnGage. If the screen capture is dark, the player’s video port may not be the problem. Make sure that content is programmed correctly. If you see content displaying in the screen capture but nothing displaying on the monitor, please request an RMA.

 

6. Audio/sound card failure

þ Confirm that the programmed content contains audio and that audio playback works.

þ Confirm that the player’s audio output is set correctly in EnGage Site Settings**:

**Note: The player must be connected to the network in order to download any settings changes. Please contact ComQi CSD if you are unsure about audio output settings in EnGage.

þ Confirm that volume is enabled in EnGage Site Settings and Screen Settings:

þ If using Analog output: Power on the player. When audio playback begins plug a known-to-work pair of headphones or speakers into the player’s green 3.5mm audio jack. If you do not hear audio please request an RMA.

þ If using HDMI output: Make sure that the correct player model is selected in EnGage:

The audio output in EnGage Site Settings must be set to HDMI. Power on the monitor and confirm that the source is set to HDMI. If the monitor uses external speakers, make sure they are powered on. Confirm that the monitor or speaker volume is turned up. Power on the player. If you do not hear audio once playback begins please request an RMA.

 

7. Ethernet port failure (No network light)

þ Power off the player. Take the CAT5 cable out of the player and plug into a network-ready desktop or laptop computer. Confirm that you are able to connect to and browse the internet.

þ Plug the CAT5 cable back into the player and power it on. If you do not see the Ethernet port link lights please request an RMA.

 

8. Noisy fan

Fan failure is sometimes caused by dust buildup in the fan vents. It can cause the player to overheat.

þ Turn off the player. If the “buzzing” sound stops, this indicates that sound is due to a faulty fan. Please request an RMA.

 

9. ComQi splash page reboot loop

An inserted USB thumb drive can cause the player to continuously reboot to the “ComQi” splash page.

þ Make sure all USB thumb drives are removed from the player. If the issue persists please request an RMA.